Samstag, 13. Dezember 2008

Huawei e169 - Reloaded

With help from Agus Priyadi I worked around the Bug that forced me to disable the 2nd Core of my Dual-Core Notebook. To make it easier for other People to find the necessary Information, I repeat his Tips:

1. Download the Patch:

host:# wget -c http://chototsumoushinp.dip.jp/solaris/usbser.tar.bz2

2. Untar the Patch:

host:# tar -jxvf usbser.tar.bz2

3. Backup existing Files:

host:# mkdir ~/backup
host:# cp /kernel/misc/usbser ~/backup/usbser.i386.orig
host:# cp /kernel/misc/amd64/usbser ~/backup/usbser.amd64.orig

4. Apply Patch:

host:# pfexec cp usbser/i386/usbser /kernel/misc/usbser
host:# pfexec cp usbser/amd64/usbser /kernel/misc/amd64/usbser
// change owner file
host:# pfexec chown root:sys /kernel/misc/usbser /kernel/misc/amd64/usbser

5. Reboot:

host:# reboot

And thats all!

Donnerstag, 13. November 2008

SSH-Login and Nautilus sftp://

I wanted to access my Fileserver with Nautilus by just typing "sftp://fileserver-ip/path", but I only got the Error-Message shown in the following Picture:


Because a Login via ssh and sftp on the Command Line took some Time between the Command and the Password-Prompt, I thought the Error-Message was caused by a Time-out. So I looked for something to speed up the Login.
What I found was:

Edit the File /etc/ssh/sshd_config

Append the Lines:
LookupClientHostnames no
VerifyReverseMapping no


Now I can use Nautilus to access my Fileserver, like I used to do with Konqueror and the fish://-Plugin.

Montag, 20. Oktober 2008

Digging Deeper I: RBAC

So Opensolaris is up and running on my Notebook, now it's Time to "look behind the Scenes". Every Post wich is called "Digging Deeper" will provide Information you our I won't actually need to solve a Problem, but is interesting to know and to understand the System.

First Thing I want to write about is RBAC (Role Based Access Control). This is the Opensolaris Way to handle User-Rights. Instead of having a Root-User who can perform all the Administration-Tasks, with Opensolaris you can give a User the Rights he needs to perform his Tasks. For Example a Web-Developer can administrate a Database, but doesn't have all the Priviliges he would have if he had used "su" or "sudo".

For further Information, there are other Blogs (Ben Rosewoods Blog) and of Course the Documentation by SUN (System Administration Guide [Chapter 17-19]), wich is as detailed as ever.

I have created a simple Java-Exampleproject with Netbeans, just to play around with the RBAC-Stuff. Right now, it only reads the File with the User-Attributes.

Donnerstag, 2. Oktober 2008

Replacing a Bootdisk without re-Install

Jignesh K. Shah describes in this Post of his Blog how you can move the Bootdisk of an Opensolaris-System over to another Disk without reinstalling the OS. It is a really good Step-by-Step-Howto, so I won't repeat any Step here.

Mittwoch, 1. Oktober 2008

Huawei e169 USB UMTS GPRS Modem

I have the Huawei e169 USB UMTS Modem and want to make it work under Opensolaris. In the Opensolaris.org-Forums I found two Threads [1, 2] about this Topic (just with other Hardware).
Problem with this Device is: If you plug it in, it first shows up as a Storage Device (wich contains the Driver-Software for WinXP). But if you connect it before you start your Engine, there's no Problem.
Before you can use the Modem, you have to associate it with the driver "usbsacm":

host:# update_drv -a -i 'usb12d1,1001' usbsacm
//NOTE: This is for the e169 ONLY, you have to
// replace the bold Numbers with those appropiate
// for your device
host:# devfsadm

You can test it easily with:

host:$ tip /dev/term/1
OK // output from tip
ati // input from you
Vendor-and-Product-Stuff // output from tip

Before you can dial-in, you have to create (or copy) several files located under /etc/ppp and /etc/ppp/peers. You can copy the isp-chat and the isp-Script from [1] and change it to your needs (dial-in-number, username, password, accesspoint; replace isp with the name of your Internet Service Provider).
If you have a Multiprocessor-System, then you have to disable all Cores except one. Otherwise the Connection will drop, when you start browsing the Internet with Firefox (BUG: 6719062)!

host:# psrinfo
// returns the cpus
host:# psradm -f
// this disables the cpu with that number
// with psradm -n you can enable the cpu

Now you can dial in:

host:$ pfexec pppd debug call isp

Right now, I am writing this with Opensolaris running.

Montag, 29. September 2008

Installing Java 6

Download Java for Opensolaris here. Choose your Platform "Solaris x86" or "Solaris x64". Select the "*.sh"-File and download it. Copy the File to /opt (Note: You will need Root-Priveleges):

host:# cp jdk-6u7-solaris-i586.sh /opt/

Now you can simply run the Shellscript:

host:/opt# sh jdk-6u7-solaris-i586.sh

The Script shows you the License for the JDK, you have to type "yes" (or "no") and the Installtion will go on and complete after a while.

Of Course, with Opensolaris and a fast Internet Connection you can use the Image Packaging System (IPS). But I don't know wich Java-Version is in the Repository.

Samstag, 20. September 2008

Sound for Opensolaris

To enable Sound for my IBM z61m I had to install the OSS. The Installation was pretty easy. You can download a Package for Opensolaris and install it:

host:# pkgadd -d oss-solaris-v4.0-1016-i386.pkg

I just selected the Default Answers during install. Now it works and I can use the Fluendo-Plugin to listen to my mp3's.

Freitag, 19. September 2008

MP3 Plugin

If you want to listen mp3's on Opensolaris, you need the Codec for MP3. You can get it for free (just for Registration) from Fluendo-Webshop.
There is a good Install-Howto inside the Archive you will get from the Webshop.

Local DNS

I wanted to get rid of typing the IP-Adress everytime I want to ssh to another PC in my LAN. Accidently I found this Solution (The Observatory - Local Hostname Resolution):

host:# cp /etc/nsswitch.conf /etc/nsswitch.conf.org
host:# cp /etc/nsswitch.dns /etc/nsswitch.conf
host:#
host:# svcadm enable /network/dns/multicast

Now you can use the Hostname and .local to ssh or whatever to a PC in your LAN.

$ ssh myhost.local

ZFS Root Mirror

This is a simple Tutorial how you can create a bootable ZFS Root Mirror with Opensolaris. I had some help from both Opensolaris-Forums (com/org) and this Blog from Malachi.

And here we go with the Tutorial:

Making a bootable ZFS Root Mirror

1. Install Opensolaris to Disk A (c3d0s0).

2. Format Disk B (c3d1s0) properly:
host:# format
(choose fdisk)
(create 100% Standard Solaris Partition over the full Disk)

3. Overwrite the Diskformat properly:
host:# prtvtoc /dev/rdsk/c3d0s2 | fmthard -s - /dev/rdsk/c3d1s2
(NOTE: s2! on BOTH Disks)

4. Attach Disk B to the ZFS Root Pool:
host:# zpool attach -f rpool c3d0s0 c3d1s0

5. Install the GRUB-Stuff to Disk B:
host:# installgrub -m /boot/grub/stage1 /boot/grub/stage2 /dev/rdsk/c3d1s0

6. Test the worst Case: Disk A fails, you can still boot into Disk B
- Remove Disk A
- Replace it with an emtpy Disk C
- Start the System: Choose to boot from Disk B in the Bios
- Repeat Steps 2. till 5. for Disk C (swap c3d0s0 and c3d1s0)
- Start the System like before (from Disk C)